Unable to get the packages in Xcitium due to some issue with olde, currently unused, Itarian account

I clicked the link to Xcitium Enterprise Platform and try to login with my Comodo/Itarian normal e-mail and it works.

When trying to deploy to a client I first get a message about Please provide Credit Card information and a link to my former Itarian account.

Since that is not in the video tutorial for enrolment I skip it, but then I notice that the packages I am supposed to select are not active. I am not allowed to post that image in this post, will follow up below.

I did have an active Itarian sub, years ago. I am trying to use the same e-mail I always used with Itarian and Comodo. I have e-mailed the Itarian support for assistance last Friday but no response yet. When making a Ticket via Comodo - Powered by Kayako Help Desk Software they tell me I should e-mail Itarian.

I have no clue what is going on. Spoke to a friendly guy at the Itarian Forums and he seems a bit puzzled about this.

Pretty fedup with what seems to be a runaroaund and mix of three different systems with seemingly shared customer database.

This is how it looks in Xcitium:

image

hi @SecCon ,

Apologize that you are facing this issue. I am checking with the team regarding the issue from my end. I will get back to you once received feedback.

you can also drop an email all the details to " support@xcitium.com " which will automatically create ticket. Internal discussions about your issue have already begun and opening a ticket provides us with a communication path between you and support. Please make sure to include your contact information when you drop the email.

Thank you!

Since I already had 1 support ticket and currently waiting for a reply from support@itarian.com I feel a bit reluctant to contact additional support resources. You see, I am a support systems services specialist and know very well how excessive contact points may cause confusion, so forgive me if I wait a bit more until doing that.

“Thank you for your support and understanding”

Could you please share the ticket number , so that I can reach out to the internal support team with the reference ticket# and try to get this issue resolved as soon as possible

I emphasis “had” a support ticket, in which they told me to send an e-mail to support@comodo.com and then I was advised to send an e-mail to support@itarian.com . I have no additional ticket number. And no reply from neither of those addresses .

I can share the old one though #RKI-634-91659

Actually, reviewing that now that ticket was not really about the current issue, it was before I managed to get the login working with a bit of reset acrobatics.

I really suggest you to drop an email all the details to " support@xcitium.com " which will automatically create ticket. You will receive automated reply email with ticket number. The follow up process is also will be crystal clear as all you would require is to reply back to the same reply email with your queries and doubts which you receive back.

Sure, will do. Hope those guys behind that has all relevant access.

Ticket 4869849 created

Thank you @SecCon , I am following up with the team internally , I will share you feedback once received.

1 Like

Solved.

Now for other challenges. :slight_smile:

Glad to hear that the issue is resolved! Please feel free to reach out to our team for any assistance required!

Thank you!